Calculs et fonctions

Exercice : Conditions (fonction SI)

Il est parfois nécessaire de définir une formule qui affecte un contenu différent selon le contexte. Par exemple, une liste de points d’étudiants. En fonction de la moyenne de l’étudiant, nous décidons s’il réussit son année ou pas.

Les champs grisés sont des champs calculés.

  • Reproduisez ce tableau.excel-fct-15

  • En F2, faites la moyenne des 3 cotes et affichez le résultat en pourcentage (=MOYENNE(C2:E2)*0,05).

  • En G2, nous allons utiliser la fonctionSI.
    SI l’étudiant à 60% ou plus de moyenne (condition), alors il réussit (valeur_si_vrai), sinon il échoue(valeur_si_faux). La formule est donc =SI(F2>=60%; »réussi »; »échec »).

L’argument condition doit obligatoirement être de type booléen (soit VRAI, soit FAUX). Les autres arguments peuvent contenir du texte, des nombres ou d’autres fonctions (voir imbrication de fonctions).

Les opérateurs logiques sont :

  • x>y donne VRAI si x et strictement supérieur à y.

  • x>=y donne VRAI si x est supérieur ou égal à y.

  • x<y donne VRAI si x est strictement inférieur à y.

  • x<=y donne VRAI si x est inférieur ou égal à y.

  • x<>y donne VRAI si x est différent de y.

  • x=y donne VRAI si x et y sont égaux.

Résumé

Dans cet exercice, nous avons vu :

  • La fonction de condition SI() ;

Fonctions logiques

Excel propose aussi des fonctions logiques, qui peuvent être utilisées dans les tests conditionnels :

  • ET(x ;y 😉
    Renvoie VRAI si tous les arguments sont vrais.

  • OU(x ;y 😉
    Renvoie VRAI si l’un des arguments au moins est VRAI.

  • NON(x)
    Renvoie VRAI si l’argument est FAUX.

Imbrication de fonctions

Exercice  : imbrication et logiqueexcel-fct-16

L’imbrication de fonction est l’utilisation d’une fonction dans une autre. Souvent, l’utilisation d’une seule fonction est insuffisante, il faut utiliser une fonction sur un résultat d’une formule ou d’une autre fonction. Imbriquer une fonction consiste à remplacer des opérandes par d’autres fonctions. Par exemple, un élève peut réussir s’il a plus de 60% au total ET s’il a au minimum 10/20 dans chacune des branches. Si on modifie l’exercice précédent pour tenir compte des nouvelles contraintes :

La formule en G2 devient donc : SI l’étudiant fait plus de 60% ET que sa cote MINIMALE est de 10/20, alors il réussit, sinon il échoue.

=SI(ET((F2>=60%) ;(MIN(C2:E2)>=10)) ; »réussite » ; « échec »)

Les fonctions ET et MIN sont imbriquées dans la fonction SI.

Print Friendly, PDF & Email